PHP Application runs through development fabric but server error 500 in cloud - Eclipse (Galileo)

Nov 26, 2009 at 12:36 PM

Here is the process so far done with errors in details , Please let me know how to resolve this issue

Project Name : OIB , 
Type : Windows Azure Web Project , 
Eclipse verion : Galileo

Steps done during development 

1. A single page PHP application alongwith the SDK  has been configured with Open Eclipse version ( Galileo )
2. The application ran sucessfully in developement Fabric with 2 Web Role instances.
3. While deploying to windows Azure with 'Publish Application to Windows Azure Portal' , all the files have been created under the following folder except for the main service package file required OIB.cspkg.



Reason for not generating the OIB.cspkg is :

C:\Project\WorkSpace\OIB\ServiceDefinition.csx\roles\WebRole\approot\Web.roleconfig (1, 1): Error  CloudServices152 : Invalid FastCGI application path '%RoleRoot%\approot\php\php-cgi.exe': path must refer to an existing file

4. Then OIB.cspkg has been created ( main service package file ) using the following command line 

C:\Project\WorkSpace>cspack OIB\ServiceDefinition.csdef /role:WebRole;OIB_WebRole /out:OIB.cspkg

5. The required two file have been deployed into Windows Azure Cloud without nay error 


Attched , Pl. find 5 files taken during the development phase

1. project folder structure in eclispe
2. Local depolyment in Fabric
3. Page coming After local deployement in fabric
4. During Azure Deployment Stage
5. After Deploment to Windows Cloud.

Observation : No auzure deployable ready-made apps was found except for SpendidCRM which eventauallu found not workable.